Help Center

Follow

Failed to Connect to the Server: Client and Server Versions Don't Match

Purpose:
You receive one of the following errors when attempting to connect the PDQ Client Mode instance to the PDQ instance running in Server Mode:

Server and Client versions don’t match, Client must be upgraded to {ServerVersion}

Server and Client versions don’t match, Server must be upgraded to {ClientVersion}

NOTE:
The PDQ instance running in Server Mode will not show an error if the client version does not equal the server version. Only PDQ instances running in Client Mode will show the error. 

Resolution:
In order for the program to function properly, the same version of the program must exist for all clients and the server.

In the case of the Server and Client versions don’t match, Client must be upgraded to {ServerVersion} error, update the client to the same version as the server.

In the case of the Server and Client versions don’t match, Server must be upgraded to {ClientVersion} error, update the server to the same version as the client. Keep in mind that any clients connected to the server using the same version as the server will also need to be upgraded as part of the process.

It's generally a good practice to keep the PDQ installers on a UNC path that can be accessed by the server and client instances. This will make upgrading easier and more efficient.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk