Help Center

Follow

Central Server: Migrating Existing PDQ Inventory Installations with Custom Collections, Tools, Scan Profiles, and Reports

Purpose:
You wish to utilize the Central Server feature in PDQ Inventory version 13 and higher (requires an Enterprise license) in an established PDQ Inventory environment that may contain custom collections, Tools, Scan Profiles, and Reports. 

Resolution:
While the instructions contained in Configuring Central Server are for new installations of PDQ Inventory (version 13 or higher), there may be situations where PDQ Inventory is updated from versions prior to 13. In those cases and where the PDQ Inventory console will be operating in Client Mode, it may be necessary to export/import collections, tools, scan profiles, and reports from previous versions or Local Mode prior to configuring an existing PDQ Inventory console to Client Mode. 

IMPORTANT:
When exporting/importing custom tools that require the use of a file, such as those utilizing Dameware or PsExec, the files must exist on the PDQ Inventory console(s) where the tool will be initiated, whether the PDQ Inventory console is running in Server or Client Mode.  

To export/import from a PDQ Inventory console that will be converted to Client Mode, perform the following:

1. In the main window of a PDQ Inventory console running in Local Mode, select the custom collections you wish to export (pre-built collections do not need to be exported). Right-click the selection and click Export from the context menu.
01.png

Next, click on the Tools tree item in the navigation pane, select one, some, or all custom Tools, right-click the selection, and click Export from the context menu.
02.png

Click on the Reports tree item in the navigation pane, select one, some, or all custom Reports, right-click the selection, and click Export from the context menu.
03.png

NOTE:
If you have a lot of custom reports mixed in with the pre-built reports that come installed with PDQ Inventory, you can create a separate Reports folder in the navigation tree, move all custom reports to that folder and then export the folder using the method outlined above. This has the added benefit of organizing all imported reports in the PDQ Inventory server console.

Finally, export your custom scan profiles. Go to File > Preferences > Scan Profiles (PDQ Inventory version < 13) or Options > Scan Profiles (PDQ Inventory version 13+). Select one or more custom scan profiles, right-click the selection, and click Export from the context menu.
04.png

IMPORTANT:
Other items that may be exported/imported using the same method outlined above are Custom Fields and Variables. If you make use of either or both of these, please export and then import them into the PDQ Inventory server console. This is especially important if you have reports and collections based on variable or custom fields.

2. Save the XML files (collections, tools, scan profiles, reports, variables, and custom fields) in a location accessible by the PDQ Inventory console running in Server Mode (e.g. a UNC share) or to external media. TIP: If you have admin access to the PDQ Inventory console that will be converted to Client Mode, you can access the C$ of the potential client from the server console of PDQ Inventory and copy the XML files directly onto that machine.

3. On the PDQ Inventory console running in Server Mode, click File > Import (or Ctrl+I), navigate to the saved XML files from step 2 and import the XML files.

4. Any custom collections, tools, scan profiles, reports, variables, and custom fields will then be imported to their respective locations in the PDQ Inventory server console. All Client consoles will then have access to the custom collections, tools, scan profiles, reports, variables, and custom fields that have been imported.

5. Proceed to configure Client Mode on the PDQ Inventory console designated to be the client.

If a PDQ console in Client Mode needs access to any collection, tool, scan profile, or report that had previously existed within their local repository but was not exported, the Client Mode console can be switched back to Local Mode, (connecting to  the original/local database for that console), which includes the custom collections, tools, and reports. Those custom elements can then be exported.

See Also:
Configuring Central Server
Sharing has Been Superseded by the New Central Server Feature

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.