Help Center

Follow

Important: PDQ Deploy 14.2 or Later Required To Download New Packages

Purpose:
This is an important, time-sensitive notification of signature changes impacting PDQ Deploy’s Package Library after 1 October 2017.

Impact:
On 1 October 2017 the old Admin Arsenal Authenticode signature for the Package Library will expire. The Authenticode signature for PDQ.com will be used after this date. Versions of PDQ Deploy older than version 14.2 (released on 21 August 2017) will no longer be able to download new packages from the Package Library.

Scope:
This will impact Free, Pro, Enterprise, and Enterprise SL customers currently using PDQ Deploy versions lower than 14.2.

Resolution:
Customers will need to update to PDQ Deploy version 14.2 or greater on or before 1 October 2017. PDQ Deploy 14.2 is aware of the new Authenticode signature for PDQ.com and will function normally without user intervention.

Existing customers can update to the latest version using the following methods:

  • Click on Help > Check for Updates from within PDQ Deploy.
    authenticode-01.png
  • Click on the New Version Available in the bottom right-hand corner of the Status Bar.
    authenticode-02.png

In addition, existing customers are encouraged to sign up to receive update notices by email.

New customers can obtain the latest version of PDQ Deploy from the following:
Download the Enterprise Trial of PDQ Deploy
Download the Free Version of PDQ Deploy

Was this article helpful?
0 out of 1 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.