Help Center

Follow

COMException

Description

An unknown error happened within Windows.

Possible Causes

In the More Info window expand the Details section. If the Scanner that failed was Windows Features please verify that the Windows Modules Installer service on the target computer is NOT disabled. If it is disabled, please re-enable it (it can be set to Manual) and retry the scan. If this does not resolve the issue, read on.

The cause of the error will depend on its error message and where the error occurred. This is often a problem with some corruption in the WMI Repository. If the error occurred while

Recommended Fix

Fix must take place on the target computer.

For Windows XP run

rundll32 wbemupgd, UpgradeRepository

For Windows 2003 run

rundll32 wbemupgd, RepairWMISetup 

For Windows Vista, 7 and 2008 run

winmgmt  /salvagerepository

If the problem persists you may need to rebuild your WMI Repository. Here is a great article that I have used for years to fix my WMI problems.

http://windowsxp.mvps.org/repairwmi.htm

 

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

2 Comments

  • 0

    The instructions did not say whether to run it on the host or the target machine.  I ran it on the target (Win 7 32 bit) an it ran, but didn't clear the "More Info" message.  On the host (Win 7 64 bit) I got a "winmgmt not found" error message.

  • 0

    Hi Tuley. Repairing or rebuilding the WMI Respository will not clear the More Info message. That will be cleared after a successful scan is performed. Give the rebuild about 20 - 30 minutes to complete before attempting a new scan.

    As far as your x64 system, make sure you run winmgmt from an elevated prompt. If you still can't find it, go to %WINDIR%\System32\wbem directory and see if it exists. If it doesn't exist then you are missing a system file. You may want to run

    SFC /SCANNOW

    from an elevated command prompt.

Article is closed for comments.
Powered by Zendesk