Help Center

Follow

PowerShell Version Errors

Purpose:

You receive one of the following errors:

  • "PowerShell version 1 is not supported"
  • "PowerShell version 2 detected and an error occurred"



Interesting and unexpected results may occur when using PDQ Deploy to run PowerShell on targets with PowerShell versions 1 or 2. The majority of errors/exceptions that occur on targets with PowerShell 2 will be reported to PDQ Deploy with error code 37105.

Suppressing error results with "-ErrorAction SilentlyContinue" will have no effect on this result in PowerShell 2. In order to properly handle suppressed errors, we recommend upgrading your targets to a later version of PowerShell.

 

Resolution:

PowerShell version 1 is not supported:
Exactly as it says on the tin. PDQ Deploy does not support the usage of PowerShell version 1.

PowerShell version 2 detected and an error occurred:
Most likely, the deployment has failed due to certain incompatibilities with PowerShell version 2.

We recommend installing the latest compatible version of PowerShell for all desktop operating systems. This allows PDQ Deploy to better process any error-related information coming from PowerShell.

As of June 2016, the latest version of PowerShell is 5. Windows 7 comes with PowerShell 2 by default but can be safely upgraded to version 5.

PDQ Deploy includes a PowerShell 5 package for your installation convenience (link below), but we have also included a link to Microsoft's website for PowerShell 5.

As Always, thanks to Kris Powell, PowerShell master, who provided all the good parts of this article.

See Also:

PDQ Deploy Package: PowerShell (WMF) (With Reboot) 5.0
Admin Arsenal PowerShell Error Handling
PowerShell 5

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk