paint.net 4.1.4

11/6/2018
Free Image and Photo editing software. paint.net requires Microsoft .NET Framework 4.7.1 or higher. Requires Windows 7 or later. Does not run on Windows 8 or Server 2012. Deployment may fail with error 1603 if target does not have .NET 4.7.1 or later installed. https://www.getpaint.net https://www.getpaint.net/roadmap.html
Vendor
Paint.NET
Version
4.1.4
Architecture
32/64-bits
Category
Imaging
Package Library Subscription Level
Enterprise

deploy Download into PDQ Deploy